Installation

Installing Powercord

Prerequisites

  1. git - https://git-scm.com/downloads
  2. node and npm (v10.0.0 or higher) - https://nodejs.org
  3. Discord Canary (Powercord will only work with Canary!)

You cannot have both Powercord and another client mod at the same time injected in Discord Canary. If you have one installed, you must first uninstall it from your Discord Canary installation and then you'll be able to install Powercord.

Installation

Please ensure that you’ve installed ‘Git’ and ‘Node’ and are using ‘Discord Canary’ before proceeding through these steps. It is required, if you are on Linux, to have Discord Canary running while installing Powercord.

  1. Open a command prompt / terminal of your choice (e.g. CMD if you’re on Windows, or Terminal if you’re using Linux/macOS). Do not open your terminal as an administrator! Powercord will fail injecting if you do so.
  2. In chronological order, type each of these commands using the command prompt / terminal opened in Step 1:
    1. git clone https://github.com/powercord-org/powercord
    2. cd powercord
    3. npm i
    4. npm run plug (Linux users: you'll need to run this command with sudo)
    5. Completely kill your Discord Client (right-click Discord in the System Tray -> “Quit DiscordCanary”)
    6. Start Discord back up and Powercord should be injected!

Uninstallation

  1. Open a command prompt / terminal of your choice.
  2. Type npm run unplug (Linux users: you'll need to run this command with sudo)
  3. Completely kill your Discord Client (right-click Discord in the System Tray -> “Quit DiscordCanary”)
  4. Start Discord back up and Powercord should no longer be injected.

IMPORTANT: Make sure to do this BEFORE deleting Powercord files, else you'll end up with a corrupted Discord installation!

Walkthrough

This video was recorded on Windows, but the installation process is similar, if not the same, on all platforms.

video